Jump to content

ASUS BRT-AC828 - VPN IPSec

Rate this topic


Guest house

Recommended Posts

Guest kryzys123

Mam problem z uruchomieniem VPN'a IPSec dla urządzeń mobilnych na tym routerze. Skonfigurowałem server VPN IPSec zgodnie z instrukcją na stronie Asus'a oraz klienta VPN na urządzeniu mobilnym z Androidem 9.0 i niestety nie można zestawić połączenia. Na PPTP wszystko działa, natomiast na IPSec nie. Proszę o pomoc.

 

 

Link to post
Share on other sites
  • Replies 13
  • Created
  • Last Reply

Top Posters In This Topic

  • house

    7

Guest kryzys123
24 minuty temu, house napisał:

jakiś link do tego poradnika ?

 

https://www.asus.com/pl/support/FAQ/1033577/

 

Na Androidzie klient VPN wbudowany, bo tego z linku Asusa już nie ma.

 

Zastanawiam się tylko co dokładnie oznacza ten fragment z instrukcji?

 6.2.1   Uwaga: Jeżeli adres IP wybranego WAN znajduje się za bramą NAT, skonfiguruj port przekazywania lub ustawienia DMZ dla adresu IP.

Chodzi o adres komputera, z którego zasobów będę korzystał po zestawieniu tunelu? Czy to ma wpływ na synchronizację VPN'a?

 

Edited by kryzys123
Link to post
Share on other sites
  • Administrator
Godzinę temu, kryzys123 napisał:

 6.2.1   Uwaga: Jeżeli adres IP wybranego WAN znajduje się za bramą NAT, skonfiguruj port przekazywania lub ustawienia DMZ dla adresu IP.

to znaczy tyle co jeden router stojący za drugim, oba w trybie NAT - podwójne NAT'owanie.

Godzinę temu, kryzys123 napisał:

Chodzi o adres komputera, z którego zasobów będę korzystał po zestawieniu tunelu?

nie, publiczny adres IP routera w internecie (lub nazwa ddns)

Link to post
Share on other sites
Guest kryzys123
14 minut temu, house napisał:

to znaczy tyle co jeden router stojący za drugim, oba w trybie NAT - podwójne NAT'owanie.

nie, publiczny adres IP routera w internecie (lub nazwa ddns)

Ok. Tzn. że w trybie Host-to-Net to nie ma znaczenia, tylko Net-to-Net. A dlaczego nie mogę w takim razie zsynchronizować tunelu po IPSec?

Link to post
Share on other sites
  • Administrator
2 minuty temu, kryzys123 napisał:

Ok. Tzn. że w trybie Host-to-Net to nie ma znaczenia, tylko Net-to-Net.

ma znacznie w obu trybach jeżeli jesteś za podwójnym NAT'em...

2 minuty temu, kryzys123 napisał:

A dlaczego nie mogę w takim razie zsynchronizować tunelu po IPSec?

tego nie wiem, jakiś kawałek logu z routera i klienta posiadasz ?

Link to post
Share on other sites
Guest kryzys123
22 minuty temu, house napisał:

ma znacznie w obu trybach jeżeli jesteś za podwójnym NAT'em...

tego nie wiem, jakiś kawałek logu z routera i klienta posiadasz ?

No właśnie to jest dziwne bo w logach na serwerze nic nie widać. Jak się łączę po PPTP to logi są a jak po IPSec to nic.

 

Może powinienem w routerze, na którym uruchamiam server VPN po IPSec (BRT-AC828), w zakładce przekierowań lub w DMZ wpisać jego adres publiczny lub wewnętrzny i otworzyć porty 500 i 4500 UDT? To głupie, ale wolę spytać?

Edited by kryzys123
Link to post
Share on other sites
  • Administrator
3 godziny temu, kryzys123 napisał:

Może powinienem... ...otworzyć porty 500 i 4500 UDT?

Ale VPN się stawia żeby właśnie nie otwierać portów. Nawet UDP wolał bym mieć zamknięte.

 

Edit: Hahaha zapomniałem, że testuje akurat WireGuard-a i sam mam otwarty port UDP... ?

 

3 godziny temu, kryzys123 napisał:

w DMZ

Chcesz sobie napytać biedy!? Nie wiem dlaczego jeszcze istnieje możliwość włączenia strefy DMZ, a przynajmniej dlaczego nie jest mocno ukryta!

 

A czemu akurat IPSec?

Edited by Guest
Link to post
Share on other sites
Guest kryzys123
14 godzin temu, Idanit napisał:

Ale VPN się stawia żeby właśnie nie otwierać portów. Nawet UDP wolał bym mieć zamknięte.

Edit: Hahaha zapomniałem, że testuje akurat WireGuard-a i sam mam otwarty port UDP... ?

Chcesz sobie napytać biedy!? Nie wiem dlaczego jeszcze istnieje możliwość włączenia strefy DMZ, a przynajmniej dlaczego nie jest mocno ukryta!

A czemu akurat IPSec?

Jak wiemy PPTP nie jest bezpiecznym protokołem. Chciałem uruchomić VPN IPSec, żeby zwiększyć bezpieczeństwo.

Link to post
Share on other sites
  • Administrator
16 minut temu, kryzys123 napisał:

Jak wiemy PPTP nie jest bezpiecznym protokołem. Chciałem uruchomić VPN IPSec, żeby zwiększyć bezpieczeństwo.

To uruchom OpenVPN, moim zdaniem w niczym gorszy a w wielu aspektach lepszy niż IPSec. Na pewno prostszy w konfiguracji... Z tym, że na androidzie wymaga oddzielnej apki.

BTW, PPTP jest dużo bezpieczniejszy niż DMZ ? Kilka godzin i miałbyś splądrowaną cała sieć i to nie raz i nie dwa ?

 

Edited by Guest
Link to post
Share on other sites
Guest kryzys123
9 godzin temu, Idanit napisał:

To uruchom OpenVPN, moim zdaniem w niczym gorszy a w wielu aspektach lepszy niż IPSec. Na pewno prostszy w konfiguracji... Z tym, że na androidzie wymaga oddzielnej apki.

BTW, PPTP jest dużo bezpieczniejszy niż DMZ ? Kilka godzin i miałbyś splądrowaną cała sieć i to nie raz i nie dwa ?

Niestety musi być IPSec, bo oprócz Androida musi działać też na IOS'ie, a jak wiadomo IOS nie wspiera już nic oprócz IPSec, L2TP i IKE v2.

Link to post
Share on other sites
  • Administrator

Ale to znaczy, że aplikacja OpenVPN jest usunięta z app store? Bo na pewno kiedyś była i działało to bez problemów.

Link to post
Share on other sites
  • Administrator
3 godziny temu, Idanit napisał:

Ale to znaczy, że aplikacja OpenVPN jest usunięta z app store? Bo na pewno kiedyś była i działało to bez problemów.

jest do dzisiaj: https://apps.apple.com/us/app/openvpn-connect/id590379981

Cytat

This app is only available on the App Store for iOS devices.

;) Różnica polega na tym, że vpn nie jest natywnie częścią iOS, tylko osobną aplikacją.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • konrad573
      By konrad573
      Witamj jest problem. Przepraszam że kolejny i kolejny temat. Nie mogę se poradzić. Mam internet multimedie na początku było ok a szczególnie jak był sam modem od nich technnicolor. Był technik to powiedział że tryb mostka jest włączony w zależności od jakiej mam umowy, że jeżeli mam bez usługi wifi w umowie to jest tryb mostka od początku włączony. A jak był montarz tego internetu to miałem pamiętam chyba ten router już i nie podłączył mi routera tylko sam modem do komputera kablem ethernet i konfigurował sieć wif(innny technik, ten co montował.) W umowie nie piszę nic że mam usługe z wifi. Porty działają jak trzeba. Problem jest Taki że od jakiegoś czasu Internet co ileś zrywa i piszę rozłączono lub nie znaleziono adresu dhcp twojego dostawcy. Mam dynamiczne ip z puli publicznej. Myślę że router nie może znaleźć ip w momencie zmiany. Resetowałem, przywracałem początkowe ustawienia a nawet wgrywałem na nowo firmware(oprogramowanie).
    • konrad573
      By konrad573
      Witam. Mam publiczne ip, router asus rapture ac 2900. Wszystko chyba ok działa. Jest problem jedynie że upnp mimo że jest włączone to nie znajduję: Port mapowania UPnP NAT:    Nieudane [MiniUPnP (http://miniupnp.free.fr/)]. Aktualizowałem oprogramowanie, nic chyba nie ruszałem. A włączone jest upnp ,ale ponowne włączanie nic nie daję. Wcześniej było tak żę było że znalazło i adres routera był i działało. Z portami przekierowywania nie ma problemu są otwarte. Na samym modemie technicolor też upnp nie działa. Dużo wcześniej było też że na samym modemie upnp nie działało a na routerze bez problemu. A teraz nawet na routerze nie działa.
    • Piotr Krupicki
      By Piotr Krupicki
      Witam
      Mam dostawce internetu Supermedia - łącze 250Mb/s Dostarczają internet przez urządzenie Halny. Na początku prędkość po wifi była identyczna jak po kablu (router Asus RT-AC88u).
      Pewnego dnia sobie sprawdzam a tu niespodzianka, max po wifi 150-160Mb/s. Sprawdziłem na wielu urządzeniach - telefony, komputery itd....
      Zawsze używałem sieć 5Ghz, kanały miałem ustawione na Auto, sprawdziłem zagęszczenie w bloku i ustawiłem kanał na 100.
      Żadnej różnicy, oczywiście wgrywałem nowe firmware, schodziłem w dół, przywracałem do ustawień fabrycznych. Co może być tego przyczyną?
      Oczywiście Supermedia umywa ręce, zwala na infrastrukturę w domu, ale testowałem również połączenie z Asus RT-1900U, który to router mam ustawiony w imesh. I to samo cały czas.
      Co może być powodem? Nic nie dokupiłem, nic nie było zainstalowane co mogłoby powodować obniżenie transferu.
       
      Dziękuję za jakiekolwiek rekomendacje, stawiam na ISP ale migają się z winą 😞
       
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, please see ours Guidelines and Privacy Policy.