Jump to content

Asuswrt-Merlin - przestało działać FTP

Rate this topic


Recommended Posts

Guest Chris_Kr

Witam wszystkich jako nowy na Forum.

Mam router RT-AC68U z Merlinem na pokładzie, do którego w charakterze dysku sieciowego mam podłączony HDD USB 3.0 i od czasu do czasu przy pomocy Total Commandera na ten HDD przerzucałem sobie pliki z peceta.

Dzisiaj nagle odkryłem, że Total Commander stracił możliwość połączenia się po FTP z routerem. Rozpoczyna nawiązywanie połączenia, w okienku wyświetla się username oraz adres IP routera, a potem komunikat "Nawiązanie połączenia się nie powiodło".

Z innymi serwerami FTP łączę się bez problemu, do routera loguję się przez http oraz putty, natomiast połączenie przez TC się nie udaje.

Problem zauważyłem po raz pierwszy mając jeszcze zainstalowanego Merlina 384.4_2, aktualizacja do najnowszej wersji 384.5_0 nic nie poprawiła. Wersje 380.x działały bez problemu, przy aktualizacji do wersji 384.x nie zmieniałem żadnych ustawień.

Czy macie jakieś pomysły, co może być przyczyną?

 

Edited by Chris_Kr
Link to post
Share on other sites
  • Administrator

to samo dzieje się np w filezilla ? pokaż log z połączenia ftp z TC lub filezilla.

Link to post
Share on other sites
Guest Chris_Kr

Połączenie przez TC tak wygląda, jak na screenie, nic więcej nie ma.

Total Commander - FTP.jpg

Pod Filezilla log wygląda tak:

Cytat

Status:    Łączenie z 192.168.1.1:21...
Status:    Nieudana próba połączenia z "ECONNREFUSED - Połączenie odmówione przez serwer".
Błąd:    Nie można połączyć się z serwerem
Status:    Oczekiwanie na ponowienie...
Status:    Łączenie z 192.168.1.1:21...
Status:    Nieudana próba połączenia z "ECONNREFUSED - Połączenie odmówione przez serwer".
Błąd:    Nie można połączyć się z serwerem

 

Edited by Chris_Kr
Link to post
Share on other sites
  • Administrator

wygląda na to, że albo ftp nie działa albo działa na innym porcie niż domyślny. pokaż screen z ustawień routera.

Link to post
Share on other sites
Guest Chris_Kr

Też zacząłem to podejrzewać, bo po wpisaniu polecenia "ps" nie widzę żadnego procesu, który mógłby się kojarzyć z FTP, a przecież jakiś demon FTP powinien tam w tle działać.

O screena której zakładki Ci chodzi? Bo jest ich dosyć sporo, ale na żadnej z nich nie widzę ustawień dla FTP!

Edited by Chris_Kr
Link to post
Share on other sites
Guest Chris_Kr

Zrobiłem downgrade Merlina do wersji 380.69_2 i magicznym jakimś sposobem FTP zaczęło działać, widoczny też jest proces vsftpd, którego w wersji 384.5 jakoś nie było widać.

Na razie pozostaję przy tej starej wersji Merlina.

W głowę zachodzę, dlaczego nikt inny tego problemu nie zgłaszał?

Link to post
Share on other sites
  • Administrator
39 minut temu, Chris_Kr napisał:

W głowę zachodzę, dlaczego nikt inny tego problemu nie zgłaszał?

może zbyt mało osób używa tej funkcjonalności lub nie zrobili jeszcze aktualizacji :) 

39 minut temu, Chris_Kr napisał:

Zrobiłem downgrade Merlina do wersji 380.69_2 i magicznym jakimś sposobem FTP zaczęło działać, widoczny też jest proces vsftpd, którego w wersji 384.5 jakoś nie było widać.

jeżeli masz możliwość, zrób upgrade, przywróć router do ustawień fabrycznych i jeśli sytuacji się powtórzy wyślij bugreport do RMerlin [email protected]

Link to post
Share on other sites
  • Administrator
Temat został zamknięty jako rozwiązany.

W przypadku jakichkolwiek pytań lub wątpliwości proszę użyć funkcji "Zgłoś odpowiedź". 

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, please see ours Guidelines and Privacy Policy.